Problem #
Some of our users have reported having issues connecting to their host when Windows 10 has been automatically upgraded to Windows 11. When this happens the host computer typically shows as online but the connection keeps returning to the connect screen instead of connecting. Alternatively you may see an error that says that more than one concurrent user cannot be logged in; or it may say that someone is already logged in and are they ok to be disconnected.
Whatever the issue may be following an upgrade to Windows 11, have no fear! MyQuickCloud works just as well with Windows 11 as it does with Windows 10, we just need to update the MyQuickCloud Server application on the host.
Cause #
Windows 11 looks and feels very similar to Windows 10, so it may not seem like a huge leap. In fact, there are lots of changes that are carried out when Windows upgrades, including the locations of various system files. The MyQuickCloud Server application needs to update the locations of these files and make a few other changes in the background.
Solution #
The solution is easy! Just run the latest MyQuickCloud Server installer from your host computer. There’s no need to uninstall the old MyQuickCloud Server application, or go through any of the setup steps. Just download and run the installer to allow MyQuickCloud to update itself on the changes that were made when Windows 11 upgraded.
Your host computer is the one with the programs on it that you access remotely. It’s the computer you connect TO, as opposed to the computer you connect FROM.
Additional info #
You can also find the installer on our Downloads page. Just scroll down to where it shows the MyQuickCloud Server and choose your version – either 32 or 64 bit. Not sure which version your computer uses? Here’s a helpful article from Microsoft on how to determine if you are running 32 or 64 bit.
A little tip: Unless your computer is very old, you are almost certainly running 64 bit, so you can just try the 64 bit installer and it will tell you if your system is too old.
Need help? #
If you get stuck or need any help at all, open a chat with our support team Mon-Fri 6am-6pm ET. One of our technicians can remote on and run the update for you.