Technical

Security Update – Jan 2018

As you may have seen in the news, a security vulnerability classed as “speculative execution side-channel attacks” (or more commonly referred to as Meltdown and Spectre) was discovered recently to affect many modern day processors and operating systems.

At MyQuickCloud we have taken steps to guard against these vulnerabilities within our infrastructure by following the advice from Microsoft, Apple and Amazon Web Services.

Managed Servers:

Clients that have a managed server with us, we will be installing the released Windows Server security update as soon as possible on all servers and making the recommended configuration changes. We have fully tested these changes before rolling out to you and will limit disruption by undertaking any server restarts outside of office hours.

To help us with this, we ask any clients that have one of our managed servers to log out at the end of each day when you have finished rather than just closing or disconnecting the remote session.

Self-Hosting:

For clients that use self-hosting, as always we recommend installing the latest security updates on your client and host computers and following any advice given by Microsoft, Apple and your suppliers.

For more information please see:

https://support.microsoft.com/en-sg/help/4073119/protect-against-speculative-execution-side-channel-vulnerabilities-in

 

Was this helpful?